This is the testing Godot forums! All forum posts unique to this forum will be deleted! Please use the main forums here for any posts you want to keep. All forum rules still apply.

TextureAtlas not working for Particles2D?

EzPizzaEzPizza Posts: 7Member

I'm trying to use a texture atlas with Particles2D. I want to use a specific particle texture from a .png file with multiple particles on it. The issue is: When I use an atlas with a marked region, it will still display the entire texture file at once. Am I doing something wrong or is this a bug?

Here is a screenshots to clarify.

Comments

  • boruokboruok Posts: 18Member

    Hi.
    1. Clear your atlas texture settings and simple drag and drop your sprite into texture .
    2. In CanvasItem-section click Material -> NewCanvasItemMaterial.
    3. Check Particles Animation.
    4. Specify how many horizontal and vertical frames you have in that sprite.
    5. Go into Process Material -> Material.
    6. Scroll Down and find "Animation Section" -> Offset.
    7. Specify wich frame you whant.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.