This is the testing Godot forums! All forum posts unique to this forum will be deleted! Please use the main forums here for any posts you want to keep. All forum rules still apply.

Imported gltf file not showing in editor

xJM27xxJM27x Posts: 2Member

Hello!
I need help with importing a 3d file I downloaded online.
I can open the file with my 3d viewer app without a problem. On Godot, I can see the mesh on the inspector tab but they just don't seem to show up in the editor.

You can download the file here (I use the autoconverted format):
https://sketchfab.com/3d-models/-mt-everest-128f43bac58e4798951bb309c64f328e

Comments

  • MegalomaniakMegalomaniak Posts: 2,580Admin
    edited June 2020

    I've seen an issue with importing gltf models where the static model doesn't show up since in the import settings it's set to import an animated object. Try toggling animation related settings off and re-importing(the import tab visible next to the scene tree tab in your screenshot).

  • TwistedTwiglegTwistedTwigleg Posts: 2,561Admin

    Additionally, make sure the object's scale isn't so large or so small that you cannot see it. The easiest way to check if this is happening is to select the object/mesh and press the F key to focus on it, which should scale the camera relative to the object's bounding box.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.