This is the testing Godot forums! All forum posts unique to this forum will be deleted! Please use the main forums here for any posts you want to keep. All forum rules still apply.

Game Crashing without Error in Debug-Console (FIXED: 3.2.2 RC1 is bad. RC2 works)

whiteshampoowhiteshampoo Posts: 7Member
edited June 2020 in General Support

Hi,

i need help with a project for a gamejam. Today is the deadline, and i'm really stuck.

The game crashes randomly, and without a reason. The game stucks for s seconds, then the game-window closes and "--- Debugging process stopped ---"
Usually i find all my mistakes by myself, but this time Godot give me absolutly no information what went wrong, and i have NO idea where to search...

Here is the project:
https://ufile.io/uzjg3ctp

I'm using 3.2.2 RC1 (without C#) on Windows 10

I would like to say more about the problem, but i really really don't know how to locate the problem...
Please help :'(

Comments

  • cyberealitycybereality Posts: 928Moderator

    If you launch Godot from the command line, it may show you more detailed error messages.

  • whiteshampoowhiteshampoo Posts: 7Member

    i already tried with commandlineoptions "-v -d" (verbose and debug), but nothing useful here, too :(

  • whiteshampoowhiteshampoo Posts: 7Member

    I have tried to print the name + "start"/"end" at every start/end of every possible function/method, but it seems to crash between frames...
    Help :(

  • whiteshampoowhiteshampoo Posts: 7Member
    edited June 2020

    I tried now with (Manjaro) Linux and Godot 3.2.1 stable.
    Here i can gat some output:

    [KinematicBody2D:41431]
    handle_crash: Program crashed with signal 11
    Dumping the backtrace. Please include this when reporting the bug on https://github.com/godotengine/godot/issues
    [1] /usr/lib/libc.so.6(+0x3c3e0) [0x7f12f1cde3e0] (??:0)
    [2] /opt/godot-bin/godot() [0x29c7276] (??:?)
    [3] /opt/godot-bin/godot() [0x29d1e00] (??:?)
    [4] /opt/godot-bin/godot() [0x192f50f] (??:0)
    [5] /opt/godot-bin/godot() [0x1528ed8] (??:0)
    [6] /opt/godot-bin/godot() [0xbc8274] (??:0)
    [7] /opt/godot-bin/godot() [0x1842cae] (??:0)
    [8] /opt/godot-bin/godot() [0x188587e] (??:0)
    [9] /opt/godot-bin/godot() [0x293dfb0] (??:?)
    [10] /opt/godot-bin/godot() [0x84ac4d] (??:0)
    [11] /usr/lib/libc.so.6(__libc_start_main+0xf2) [0x7f12f1cc9002] (??:0)
    [12] /opt/godot-bin/godot() [0x857fde] (??:0)
    -- END OF BACKTRACE --
    

    but this does not really help me.... :(

    EDIT:
    It's not realiable a KinematicBody2D

  • TwistedTwiglegTwistedTwigleg Posts: 2,561Admin
    edited June 2020

    Have you tried Godot 3.2.2 RC2?

    Edit: Running the project in the editor with Godot 3.2.2 RC2 works for me! I'd try exporting with Godot 3.2.2 RC2 and see if that fixes the issue.

  • whiteshampoowhiteshampoo Posts: 7Member
    edited June 2020

    also crashing in RC2...
    Also exported (64&32bit)

    EDIT:
    because i'm an idiot.
    i downloaded the RC2, but started the RC1 executable.

    Thanks, is working now! <3

  • whiteshampoowhiteshampoo Posts: 7Member

    Release-Export still crashes :D

  • MelonHeadMelonHead Posts: 1Member
    edited June 2020

    Edit: Jokes on me. That didn't fix it. Back to square one....
    Edit2: Should have read your title, RC3 fixed it for me

    I made an account just to answer you and now this site makes me type it twice because the first one never got posted..... Anyway:
    I was facing a similiar issue as you. Random but semi reliable crashes.
    After lots of trial and error i found out that it sometimes crashed when instantiating a specific scene.
    That scene consisted of a Area2D using a CollisionPolygon2D.
    I deleted the CollisionPolygon2D and started using a CollisionShape2D.
    That seems to have "fixed" it for now.
    I hope that helps you, because debugging without any engine feedback is incredibly annoying.

  • TwistedTwiglegTwistedTwigleg Posts: 2,561Admin

    @MelonHead said:
    I made an account just to answer you and now this site makes me type it twice because the first one never got posted.....

    The first one was stuck in the moderation queue, likely because your account was not verified when you posted.

  • whiteshampoowhiteshampoo Posts: 7Member

    I just saw that RC3 is out. i'll try today evening if it fixes my problem. In the meantime i "released" my game as debug-build to the gamejam. I'm not a big fan of this, but it runs without crashing :)

    (If someone is interested (Sourcecode/Project-Folder included) --> Link <-- )

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.